How to open solution in source repository?

Aug 16, 2013 at 2:01 AM
Hey guys. I'm not entirely sure how to open the solution found in the source code repo. I read in one of the threads here that it was supposed to be ported to Visual Studio 2012; I wasn't sure if that meant they were going to port the code/functionality into the Visual Studio 2012 shell, or if they were going to migrate the solution/projects into a VS2012 environment.

Either way, I've already tried opening the solution in both VS2010 and VS2012, both are ultimate editions. Both of them give some kind of failure message about how the solution wasn't made with this version of Visual Studio and none of the projects build. Everything gets imported with errors.

I'm not good with Visual Studio specific problems, especially for an undocumented project. If anyone could give me a nudge in the right direction, I'd really appreciate it.

I think RealScript IDE is pretty awesome and I'd like to continue development on it. I've actually never done any real UnrealEngine3/UDK dev work, but I really want to get into it. I'm the type of person that really loves using an IDE and this one, in my opinion, has the most potential.

Thanks :)
Aug 16, 2013 at 4:50 PM
VS2010 reports that it can't open any of the solutions because they were made in a newer version of Visual Studio. So opening it in VS2012, I get these errors:

Error ShellExtensionsVSIX UDKDevKitVSXShell\ShellExtensionsVSIX\ShellExtensionsVSIX.csproj 1 0 0
Error UDKDevKitVSXShell.MainPackage UDKDevKitVSXShell\UDKDevKitVSXShell.MainPackage\UDKDevKitVSXShell.MainPackage.csproj 1 0 0
Error UDKDevKitVSXShellSetup UDKDevKitVSXSetupShell\UDKDevKitVSXSetupShell.vdproj 1 0 0


Can someone help me get a working code base? :(
Aug 18, 2013 at 3:05 AM
I'm pretty sure this project is dead, but I figured I'd post my findings here, in case anyone else runs into the same issues.

I've resolved all except one problem. So I've installed the Visual Studio 2010 and Visual Studio 2012 SDKs. After that, open up the main solution file with your favorite text editor and change the version number to v11 and update the comment to match. So the first two lines should read as such:
Microsoft Visual Studio Solution File, Format Version 11.00
# Visual Studio 2010
And now the solution will open with Visual Studio 2010.

While this has solved quite a lot of problems, unfortunately, I'm still left with one error while opening the solution:
error : The imported project "C:\Microsoft.Cpp.props" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.
I'm pretty sure that if I install VS2010's Service Pack 1 update, this will be resolved. I'm running on a new OS build, so I didn't have SP1 installed yet. I'll do it and report back with my results.
Coordinator
Aug 23, 2013 at 10:44 AM
Edited Aug 23, 2013 at 10:49 AM
Thank you for your interest.

FOA. All project have been written in VS2010 with using VS 2010 Shell (Isolated). (It was so long ago so I do not remember all details).

If you download the file VS2012/SRC.7z from SVN it contains all files you need but it was converted into VS2012 projects. If you manage to convert it back to VS2010 you will be able to compile. the problem that I do not have VS2010 now and I can't convert it back or have a look what are the issues there. I believe it should be compilable in VS2012 except installation project which should be written from the beginning.

Contact me for any details.

BTW source in SVN is not compilable because it does not allow to store files which are not text files.
Sep 13, 2013 at 3:17 PM
So, the best way to open the solution is:
1) Install vs2012
2) Install vs2012 sdk
3) Open the solution under folder VS2012

is it correct?
Coordinator
Oct 3, 2013 at 7:56 AM
yes, it is