Debugger won't start and run isn't logged

Sep 29, 2012 at 12:31 PM
Edited Sep 29, 2012 at 1:52 PM

Hi,

I've installed IDE with everything done from Documentation.

When I run Debug the game is opening (with my map and gameinfo etc) but I don't have any log in the IDE (Debug) only information about compilation. Debugger isn't working as well.

I'm using UDK07 - anyone have this issue? 

Everything is properly configured I'm using UDK/Unreal for years now. Be grateful for help this IDE looks really great! 

Maybe it's because I haven't installed IDE to default location?

Show output is showing only Build, there is no debug info or run info from UDK. 

From Solution Properties there are Debug Sources Files and I don't have these DIRs. 

Sep 29, 2012 at 11:16 PM

I have the same problems...And when I launch the game in debug, the breakpoints are ignored...

Coordinator
Sep 30, 2012 at 10:02 AM

>>andrzejkoloska

yes, try to use default folder locations (install IDE into "Program Files" folder)

 

>>RoxXx88

have a look here 

http://uside.codeplex.com/discussions/352431

Sep 30, 2012 at 11:01 AM

I've just read the previous discussion, but I can't solve the problem. I have compiled my scripts in debug, I'm using these parameters: 

ExampleMap.udk?game=UTGame.UTGame?class=UTGame.UTPawn

but nothing...I haven't added custom modules/packages, I'm trying to debug the default UDK code (using ExampleMap)...

Oct 2, 2012 at 2:40 PM

I've used default directory and still the same debugger won't attach. There is log "Attaching Debugger" but without any debugger :) Let me know if you need more info. 

Oct 3, 2012 at 9:42 AM

Maybe this will help: even -log isnt working, window with log is opening but without anything. When I've created an .bat and open game with -log I can see my log is there but when running command line -log from IDE it's empty. 

Oct 3, 2012 at 2:48 PM

Ive deleted UDK -> reinstalled and it is working :) So maybe there is some path that isn't working correctly after install/reinstall of the IDE.

Coordinator
Oct 3, 2012 at 6:34 PM

yes, it seems you deleted dlls which intaller puts into UDK bin folder

Coordinator
Oct 3, 2012 at 6:35 PM

does the debugger hit the first execution line?

Oct 3, 2012 at 7:07 PM

Yes it's annoying but can work with that :)