Installation fails while installing Visual Studio Redist. files

Aug 22, 2012 at 12:06 AM
Edited Aug 22, 2012 at 12:25 AM

Following error message appears after the dialog box that I need to install some Visual Studio components (beside having the full VS version already installed on my machine):

 

Setup has detected that the file 'C:\Users\Radon\AppData\Local\Temp\VSDE54D.tmp\Microsoft Visual Studio 2010 Shell (Isolated) Redistributable Package\vsisoshell.exe' has changed since it was initially published.

See the setup log file located at 'C:\Users\Radon\AppData\Local\Temp\VSDE54D.tmp\install.log' for more information.

 

Interetingly enough, the logfile is empty, so I have nothing to go for. Any hints?

 

//e: Tried to download & install this VS 2010 Shell Isolated manually, problem still the same.

Coordinator
Aug 22, 2012 at 3:07 PM

try to install it again or intall VS 2010 Shell (Isolated) manually. but I see you have tried to install VS Shell already.

did you try to get it from this URL?

http://www.microsoft.com/en-us/download/details.aspx?id=1366

I hope MSFT didn't change anything....

Aug 26, 2012 at 1:12 AM

I got this error too. When I try to run the vsisoshell.exe from the temp folder that the installer extracts I get this error.

The version of this file is not compatible with the version of windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

I'm running Win 7 64 bit, so perhaps your installer is a 32 bit version?

Aug 26, 2012 at 1:45 AM

Followup, I was able to install the IDE after installing the VS 2010 Shell from the link you pasted above.