Running through Unreal Script IDE crashes the game

May 19, 2012 at 7:36 PM

Since updating to the latest version, UDKGame is crashing whenever I run through the IDE (in both release and debug mode). The game runs fine from any other location.

What could be causing this?

Coordinator
May 19, 2012 at 9:03 PM

is it possible to see any exception info or screen shots of what you was doing (all sensetive info you can remove)?

May 19, 2012 at 9:17 PM

The crash happens very soon after the game splash screen shows when hitting the green play button to launch Release or Debug configuration. There is no error message, just a general windows crash notification that says "Built with UDK has stopped working."

I have tried fully rebuilding scripts in both configurations.

On May 19, 2012 5:03 PM, "AlexDev" <notifications@codeplex.com> wrote:

From: AlexDev

is it possible to see any exception info or screen shots of what you was doing (all sensetive info you can remove)?

Read the full discussion online.

To add a post to this discussion, reply to this email (uside@discussions.codeplex.com)

To start a new discussion for this project, email uside@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
May 20, 2012 at 12:45 PM

I have seen this behavior and usually the problem happend when I tried to debug code which wasn't compiled for debugging, but if you are saying that you have rebuilt it in debug mode which should have fixed the problem.

May 20, 2012 at 3:44 PM

So I think I have something for you.

I completely uninstalled USIDE, deleted the program folder, and re-installed USIDE. Debugging worked on the first run, but has failed in the same way on subsequent attempts following a restart of the IDE.

Next, I uninstalled USIDE, and moved my UDK installation to the default location C:\UDK\UDK-2012-05 by cut-and-paste. Normally my game is located at C:\Mygame\UDK. After moving the UDK folder I re-installed USIDE and now there are no crashes with USIDE.

Then, I uninstalled USIDE, moved my UDK back to C:\Mygame\UDK via cut-and-paste, and re-installed USIDE. The crashes are back, after running correctly on the first attempt as before.

So it seems to be a problem with the install path of UDK.

Coordinator
May 21, 2012 at 8:14 AM

Thank you very much, perfect investigation!

 

Yes, I will fix it and will update IDE soon.

 

Regards