How to Use?

May 14, 2012 at 10:32 PM

Can anyone please help me?  I cannot figure out this IDE at all.  When I go to type class nothing shows up like auto complete or nothing is highlighted at all such as class, float, etc.  Is do I have to set it up in any way?  Please get back to me, I dont even see how to create a project unless it always start with a blank slate every time.  I just need to know if I need to set this up or not.  Thank you in advance.

Coordinator
May 15, 2012 at 8:33 AM

Make sure you read "DOCUMENTATION" before intalling IDE. Pay attention to section "Troubleshooting > Project is empty when you open Unreal Script IDE"

 

PS just install UDK before installing IDE, and select correct path to UDK folder as described in "Documentation > Installtion"

May 16, 2012 at 3:54 AM

I have done that.  I don't get autocomplete or anything.  I will try again like uninstall the IDE and re-installing it and following this again. 

Coordinator
May 16, 2012 at 8:17 AM

Give a bit time to finish parsing of source before using autocomplete. You should see the progress in a status bar

May 16, 2012 at 4:38 PM

Well the problem also is that I tried to make my own class also.  This is what I was trying to do in order to see if the IDE worked properly:

class MyPlayerController extends PlayerController;

 

everything there that is supposed to be highlighted isn't.  Nothing is highlighted which means only one thing.  The IDE isn't looking at the source code.  I did set up the IDE correctly or I believe so.  When installing, before I pushed install I set up the IDE via the browse buttons located with in the installation process.  Maybe I chose the wrong folders? I have no clue what to do at this point.  I will try other things but if you have any suggestions please feel free.

Coordinator
May 16, 2012 at 8:30 PM
Edited May 16, 2012 at 8:35 PM

are you using latest UDK?

which folder have you selected for UDK Binary folder when you installed IDE?

When you open the IDE do you see Project Files? 

Do you see the progress of parsing when you open IDE?

Have you added the file using Add->New Item on your Mod folder?

PS. If you installed IDE as described in "Documentation" you should not have any problems with it (of cause if you installed UDK before)

PS2. If you could create screen shots of your installation process I can tell what you are doing wrong.

May 16, 2012 at 8:51 PM

Here are the screen shots.

 

http://screensnapr.com/v/Etfn4r.jpg  //This is where I select the installation location

 

http://screensnapr.com/v/JZeqe7.jpg  //Here is the binary location

 

http://screensnapr.com/v/6O4MeS.jpg  //Conformation

 

I will next show you what I see when I look in the IDE so you will have an understanding what is going on after installation.

 

http://screensnapr.com/v/EdrcWf.jpg  //Last here is it opened and try to open a new project

May 16, 2012 at 9:23 PM

I have found the problem.  I newly installed my windows but for some reason it was getting the old location for the one I guess I uninstalled of UDK.  I selected the one that I newly installed of UDK and its being populated with classes and such.  Now to test out the IDE lol

May 16, 2012 at 9:27 PM

Still I do not see any autocomplete or intellisence kicking in.  So please help me out on that at least.  I will look in the options to see if I see anything in there I need to change in the mean time I will be awaiting on a reply on this issue.  Thank You.

Coordinator
May 16, 2012 at 9:51 PM

According to this screen shot you selected UDK folder without Source or empty UDK folder etc

>>http://screensnapr.com/v/EdrcWf.jpg  //Last here is it opened and try to open a new project

You need to read documentation section "Troubleshooting"

Coordinator
May 16, 2012 at 9:54 PM

If you do not see image like that, It means you have not selected right UDK folder or you do not have Source folder in UDK or it just invisible for the application

 

 

May 17, 2012 at 2:27 AM

Yes it looks like that now.  I am just saying that as of right now I do not have intellasence.  I do have all the source code like this picture now.  I do not know if there is an option for intellasence I have looked and cant find it.  I know I seen it before on the VS11 but for some reason I cant find it on this IDE.  Please help me with auto complete and intellasence.

Coordinator
May 17, 2012 at 2:47 PM

FOA you need to make sure that IDE highlights syntax correctly it means that it is working ok.  Autocomplete works when you press Ctrl+Space in code 

May 17, 2012 at 7:47 PM

OMG!! This is great.  if you push Ctrl+Shift before you start typing when you know you need auto-complete it makes this IDE just like programming in a regular program.  Which makes this IDE like the best one I have found for Unrealscript.  Amazing IDE.